Welcome to the ClipScribe Helpdesk!

We just launched as of June 26th, and as a new software platform, bugs are bound to happen. If you have any issues at all PLEASE post here or email Craig at craigl@clipscribe.com so we can resolve any issues as quickly as possible. Thanks for helping us make ClipScribe great!

HelpdeskCategory: Questions
Filter:AllOpenResolvedClosedUnanswered
I cannot access my videos
ClosedCarlos Adell asked 1 year ago • 
119 views0 answers0 votes
Subtitles
ClosedJason Lucchesi commented 1 year ago • 
134 views1 answers0 votes
affiliate
ClosedCraig answered 1 year ago • 
162 views0 answers0 votes
Hi – I would like a refund. We fall in the 7 day grace period.
ClosedCraig answered 1 year ago • 
154 views0 answers0 votes
Languages
ClosedCraig answered 1 year ago • 
187 views1 answers0 votes
Preview
ClosedCraig answered 12 months ago • 
149 views0 answers0 votes
Not exporting correctly
ClosedRyan Ehler asked 12 months ago • 
120 views0 answers0 votes
I would like to use the same branding each time
ClosedEddette Steynberg asked 12 months ago • 
146 views0 answers1 votes
video length
ClosedDerek Ledwidge asked 12 months ago • 
136 views0 answers0 votes
Can I saver my video branding to use each time?
ClosedCraig answered 12 months ago • 
110 views1 answers0 votes
subtitles not loading properly
ClosedRianne Klein Geltink asked 12 months ago • 
125 views0 answers0 votes
Display issues when trying to edit videos
ClosedChristina Ethridge asked 12 months ago • 
147 views0 answers0 votes
Exports
ClosedPaul Proctor answered 12 months ago • 
113 views0 answers0 votes
My video isn’t displaying. Help?
ClosedCraig answered 12 months ago • 
133 views1 answers0 votes
Need Invoice
ClosedCraig answered 12 months ago • 
143 views1 answers0 votes